關於在FreeBSD上安裝GD庫的問題解決

火星人 @ 2014-03-12 , reply:0


  關於在FreeBSD上安裝GD庫的問題解決。

系統:FreeBSD 4.1
用sysinstall將gd-1.8.3和libpng,jpeg6b安裝。確保你在usr/local/lib下有libgd.so.*和libpng.so.*

cd path_to_php_src
./configure --with-mysql=/path_to_mysql
--with-apache=/path_to_apache_src
--with-gd=/usr/local 這裡不要加lib
--with-png-dir=usr/local 同上
--enable-track-vars
--enable-discard-path
--disable-debug
其後一切照舊。

西狂兄的3.4中帶的是gd-1.7.0不知道能否支持你要的wbmp,不過我試了在3.4上用4.1的光碟add package也成 功了。FreeBSD 4.0裡面帶的是1.8.0的GD




[火星人 via ] 關於在FreeBSD上安裝GD庫的問題解決已經有110次圍觀

http://www.coctec.com/docs/unix/show-post-73993.html