求助:cman進程啟動錯誤

火星人 @ 2014-03-04 , reply:0


求助:cman進程啟動錯誤

centos6,啟動cman顯示如下錯誤,共三台hp 380,其它兩台啟動正常,求教大蝦

# service cman start
Starting cluster:
   Checking Network Manager... [確定]
   Global setup... [確定]
   Loading kernel modules... [確定]
   Mounting configfs... [確定]
   Starting cman... [確定]
   Waiting for quorum... Timed-out waiting for cluster
[失敗]
《解決方案》

兩個起來的節點的 clustat 執行一下,再就是把 /etc/cluster/cluster.conf 文件貼出來!
《解決方案》

# clustat
Cluster Status for webcluster @ Thu Nov 24 14:41:20 2011
Member Status: Quorate

Member Name                                                     ID   Status
------ ----                                                     ---- ------
web2                                                                1 Online, Local
web3                                                                2 Offline
web4                                                                3 Online

# clustat
Cluster Status for webcluster @ Thu Nov 24 14:42:21 2011
Member Status: Quorate

Member Name                                                     ID   Status
------ ----                                                     ---- ------
web2                                                                1 Online
web3                                                                2 Offline
web4                                                                3 Online, Local

# cat /etc/cluster/cluster.conf
<?xml version="1.0"?>
<cluster config_version="8" name="webcluster">
        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="web2" nodeid="1" votes="1">
                        <fence>
                                <method name="iLO3Fence">
                                        <device name="web2iLO"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="web3" nodeid="2" votes="1">
                        <fence/>
                </clusternode>
                <clusternode name="web4" nodeid="3" votes="1">
                        <fence>
                                <method name="iLOFence">
                                        <device name="web4iLO"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="web45" nodeid="4" votes="1">
                        <fence/>
                </clusternode>
        </clusternodes>
        <cman/>
        <fencedevices>
                <fencedevice agent="fence_ilo" ipaddr="172.31.152.14" login="root" name="web2iLO" passwd="root135@$^" power_wait="90"/>
                <fencedevice agent="fence_ilo" ipaddr="172.31.152.16" login="root" name="web4iLO" passwd="root135@$^" power_wait="90"/>
        </fencedevices>
        <rm>
                <failoverdomains/>
                <resources/>
        </rm>
</cluster>
《解決方案》

web45是剛加的一台想試下OK否,但clustat沒有顯示出這台,cluster.conf中有這個Node
《解決方案》

我也遇到這個問題了。集群狀態:
# clustat
Cluster Status for op-vm-cluster @ Wed Sep 25 13:17:12 2013
Member Status: Inquorate

Member Name                                                     ID   Status
------ ----                                                     ---- ------
agent21                                                             1 Online, Local
agent22                                                             2 Offline
agent23                                                             3 Offline
agent24                                                             4 Offline
agent25                                                             5 Offline
agent26                                                             6 Offline
agent27                                                             7 Offline
agent28                                                             8 Offline
agent29                                                             9 Offline
agent30                                                            10 Offline
agent31                                                            11 Offline
agent32                                                            12 Offline
agent33                                                            13 Offline
agent34                                                            14 Offline
agent35                                                            15 Offline
agent36                                                            16 Offline
agent37                                                            17 Offline
agent38                                                            18 Offline
集群配置:
<?xml version="1.0"?>
<cluster name="op-vm-cluster" config_version="18">
  <cman keyfile="/var/lib/pve-cluster/corosync.authkey">
  </cman>
  <clusternodes>
        <clusternode name="agent21" votes="1" nodeid="1"/>
        <clusternode name="agent22" votes="1" nodeid="2"/>
        <clusternode name="agent23" votes="1" nodeid="3"/>
        <clusternode name="agent24" votes="1" nodeid="4"/>
        <clusternode name="agent25" votes="1" nodeid="5"/>
        <clusternode name="agent26" votes="1" nodeid="6"/>
        <clusternode name="agent27" votes="1" nodeid="7"/>
        <clusternode name="agent28" votes="1" nodeid="8"/>
        <clusternode name="agent29" votes="1" nodeid="9"/>
        <clusternode name="agent30" votes="1" nodeid="10"/>
        <clusternode name="agent31" votes="1" nodeid="11"/>
        <clusternode name="agent32" votes="1" nodeid="12"/>
        <clusternode name="agent33" votes="1" nodeid="13"/>
        <clusternode name="agent34" votes="1" nodeid="14"/>
        <clusternode name="agent35" votes="1" nodeid="15"/>
        <clusternode name="agent36" votes="1" nodeid="16"/>
        <clusternode name="agent37" votes="1" nodeid="17"/>
        <clusternode name="agent38" votes="1" nodeid="18"/>
  </clusternodes>
</cluster>




[火星人 via ] 求助:cman進程啟動錯誤已經有175次圍觀

http://www.coctec.com/docs/service/show-post-3925.html