怎麼讓redhat 企業版的改成centos 5.3???

火星人 @ 2014-03-04 , reply:0
←手機掃碼閱讀

怎麼讓redhat 企業版的改成centos 5.3???

我自己玩的redhat enterprise  4 想用yum 改成centos ??
該怎麼改!
改什麼文件,大蝦幫個們研究以下啊啊
-_- -_- -_- -_-- _- -_-!!
小弟這裡多謝了!!!!
《解決方案》

回復 #1 chenglin4636931 的帖子

肯以肯定的告訴你,你只能升級到 CentOS4.

卸掉REDHAT   release and  notes  包。  4還要重新裝YUM包 否則升級回報錯。  

我成功改過 4.0  和5.0/1/2/3 到Centos對應的版本,可以很負責的告訴你,放心用吧。但是不要跨版本~~

參考:
去http://www.rpmfind.net/ 搜索yum  ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/yum-2.4.2-0.4.el4.rf.noarch.rpm

然後安裝。

rpm -ivh yum-2.4.2-0.4.el4.rf.noarch.rpm
可能會提示缺少一些文件或者模塊,按照名字在rpmfind.net裡面搜索

error: Failed dependencies:
         python-elementtree is needed by yum-2.4.2-0.4.el4.rf.noarch
         python-sqlite is needed by yum-2.4.2-0.4.el4.rf.noarch
         urlgrabber is needed by yum-2.4.2-0.4.el4.rf.noarch
ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-elementtree-1.2.6-7.el4.rf.i386.rpm

ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-sqlite-1.0.1-1.2.el4.rf.i386.rpm

ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-urlgrabber-2.9.7-1.2.el4.rf.noarch.rpm

ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/sqlite-2.8.16-1.2.el4.rf.i386.rpm

然後

導入一個GPG-KEY

rpm --import /usr/share/rhn/RPM-GPG-KEY


還要修改一下/etc/yum.repos.d/CentOS-Base.repo
才可以yum升級,把/etc/yum.repos.d/CentOS-Base.repo的內容替換為:


name=CentOS-4 - Base
baseurl=http://mirror.be10.com/centos/4/os/i386/
gpgcheck=1

#released updates

name=CentOS-4 - Updates
baseurl=http://mirror.be10.com/centos/4/updates/i386/
gpgcheck=1

#packages used/produced in the build but not released

name=CentOS-4 - Addons
baseurl=http://mirror.be10.com/centos/4/addons/i386/
gpgcheck=1

#additional packages that may be useful

name=CentOS-4 - Extras
baseurl=http://mirror.be10.com/centos/4/extras/i386/
gpgcheck=1

#additional packages that extend functionality of existing packages

name=CentOS-4 - Plus
baseurl=http://mirror.be10.com/centos/4/centosplus/i386/
gpgcheck=1
enabled=0

#contrib - packages by Centos Users

name=CentOS-4 - Contrib
baseurl=http://mirror.be10.com/centos/4/contrib/i386/
gpgcheck=1
enabled=0

#packages in testing

name=CentOS-4 - Testing
baseurl=http://mirror.be10.com/centos/4/testing/i386/
gpgcheck=1
enabled=0


rpm --import http://mirror.be10.com/centos/RPM-GPG-KEY-CentOS-4解決yum問題

然後現在就可以進行升級了

[ 本帖最後由 loveflag 於 2009-5-6 15:14 編輯 ]
《解決方案》

自己先頂一個哈!!!!
《解決方案》

是不是直接用以下命令
#yum  update
《解決方案》

這個問題很尖銳阿:lol: :lol:
《解決方案》

據說把源設成centos的,然後升級就可以了,沒試過
《解決方案》

具體怎麼操作的啊!!
有沒有知道!!或者做過的啊!!!
《解決方案》

跨大版本升級估計夠嗆。
《解決方案》

回復 #1 chenglin4636931 的帖子

那個不可以的
建議還是遷移
《解決方案》

直接安裝行版本,數據導入不行嗎




[火星人 via ] 怎麼讓redhat 企業版的改成centos 5.3???已經有352次圍觀

http://www.coctec.com/docs/service/show-post-22646.html