centOS6.2下編譯nagios總是提示語法錯誤

火星人 @ 2014-03-04 , reply:0


centOS6.2下編譯nagios總是提示語法錯誤

configure編譯的時候 總是提示這個錯誤:

# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether make sets $(MAKE)... yes
checking for strip... /usr/bin/strip
checking how to run the C preprocessor... -g -fPIC
configure: error: C preprocessor "-g -fPIC" fails sanity check
See `config.log' for more details.


這個問題困擾我很久了,怎麼解決呢。。是缺少什麼包嗎?還是版本問題呢。。? 請各位大神幫幫忙~ 小弟不勝感激!
《解決方案》

現在都3.5 了你還用3.2 。。




[火星人 via ] centOS6.2下編譯nagios總是提示語法錯誤已經有128次圍觀

http://www.coctec.com/docs/service/show-post-11607.html