Mozilla Firefox 3.6下使用Java瀏覽器插件

火星人 @ 2014-03-12 , reply:0


  

即將發布的 Mozilla Firefox 3.6 系列將不再支持以前 OJI (Open Java Virtual Machine Integration)架構 Java 瀏覽器插件,需要使用 Java 6 Updates 10 及以後提供的符合 NPAPI 標準的新版本瀏覽器插件。本文介紹如何在 Mozilla Firefox 3.6 下配置 Java 瀏覽器插件。

下文以從 Mozilla 官方下載的 Mozilla Firefox 3.6 Beta 4 i686 Linux 版本為例,介紹如何在 Fedora 12 下為其添加 Java 支持。

由於 Fedora 12 默認提供的 OpenJDK 6 並未包含新的 NPAPI 標準的插件,所以只能使用 Sun 的 Java。據悉,預計於2010年春/夏季發布的 OpenJDK 7 將包含此插件。預計 2010 年春季發布的 Fedora 13 將包含新的 OpenJDK 7 組件。

1. 從 Java.com 網站上下載 Java 運行時環境。這裡使用 Linux (self-extracting file) 版本。

2. 將下載好的文件拷貝到希望安裝 Java 的目錄下,為其添加可執行許可權並運行, chmod +x jre.bin && ./jre.bin ,按照提示安裝即可。

3. 在 Java 安裝目錄中找到名為 libnpjp2.so 文件,find . -name libnpjp2.so 。

4. 為其創建一個符號連接到 Mozilla Firefox 3.6 的安裝目錄下的 plugins 目錄即可。

如果你的 Java 和 Mozilla Firefox 安裝在同一個目錄下(比如像我都安裝到 $HOME/Apps 下),那麼下面這條命令可以自動完成上面的兩步: ln -vs $(find . -name libnpjp2.so) ./firefox/plugins/libnpjp2.so

重新啟動 Mozilla Firefox 即可使用這個新版本的 Java 插件了~

使用 M$ 系統的朋友可以參考 Sun 的這篇教程進行設置。

文中內容參考了 mozillaZine 論壇 內容,在此表示感謝!





[火星人 via ] Mozilla Firefox 3.6下使用Java瀏覽器插件已經有85次圍觀

http://www.coctec.com/docs/linux/show-post-66013.html